erreur suite mise à jour
#1
Depuis hier j'ai effectué la dernière mise a jour de Lifedomus.
Dans le DS, j'ai créer une page Smart vision pour tester l'ergonomie de cette page.
puis j'ai quitté la maison.
Quand je suis rentré, le portail du jardin, la porte du garage et l'alarme fonctionnait,
mais j'ai constate les erreurs sur les lampes, tel que la copie d'écran de l'Iphone ci-dessous, le montre.
( Désolé je n'arrive pas a joindre le images, ça doit être simple mais???? les équipements affichent "!")

ce matin, j'ai cherché à résoudre ce problème, et j'ai constaté que de nombreux équipements présentaient de défauts.
Voir ci-dessous l'arrosage du jardin. Après activation, l'erreur disparaît.


J'ai supposé que la page smart Vision posait des problèmes et je l'ai supprimée.
Comme il n'y avait pas de changement, j'ai décidé de redémarrer physiquement le serveur Lifedomus.
Et là, le serveur a cessé de répondre.

J'ai branché un écran pour suivre le boot.
le message annonçait que le boot avait été modifié, et il me demande si (Y) je voulais démarrer avec le Boot
ou (N) pour démarrer avec les anciens paramètres.
J'ai appelé le support, qui a fait le choix de redémarrer avec les anciens paramètres de boot.
Et le serveur est redevenu disponible.
Non avons rechargé la dernière sauvegarde connue comme stable.

Par contre toujours les mêmes erreurs, et si j'active les équipements l'erreur disparait, pour l'élément concerné.
Par contre, dès le redémarrage du serveur l'erreur revient.


Jean-Louis
Répondre
#2
Bonjour,

Suite à la mise à jour, nous avons fait certaines modifications dans notre gestion des états.
Précédemment lors d'un redémarrage d'un serveur nous conservions les anciennes valeurs (qui pouvaient être fausse).
Maintenant nous effaçons tous les états. Au démarrage par contre nous faisons une lecture de toutes les adresses KNX. Je vous recommande de vérifier votre projet KNX si les adresses de lecture ont bien le flag "read". Car une fois actionné, le module doit renvoyer son état et Lifedomus le prend donc en compte.
Vous pouvez aussi vérifier dans le CS si l'actualisation des propriétés est bien "A la connexion".

Pour ce qui est du portail, porte de garage et alarme, je vous conseillerais de regarder du côté du journal d’événements pour comprendre quand Lifedomus aurais agit sur vos équipements.

Julien
Répondre
#3
Bonjour,

Fallait-il bien redémarrer avec les anciens paramètres de boot sur le serveur ???

Jean Louis
Répondre
#4
Bonjour,

Le bios Intel n'aime pas les coupures a chaud et affiche ce message sur certains de nos premier serveur V2.
Yes ou No fonctionnent très bien l'un comme l'autre.

Julien
Répondre
#5
Çà ne fonctionne pas
Adresse lecture en read
CS à la connexion
Dès redémarrage çà se met en erreur
Si vous voulez prendre la main
Répondre
#6
Est-ce que lorsque vous faite un read via le moniteur de groupe ETS l'adresse répond quelque chose ?

Sinon vous pouvez vérifier dans le débogueur Lifedomus si lorsque vous redémarrer le connecteur KNX vous voyez bien la demande de lecture sur cette adresse et la réponse du module.

[ATTACH=CONFIG]557[/ATTACH]

Exemple ici : l'adresse 0/0/60 ne marche pas.

Julien


Pièces jointes Image(s)
   
Répondre
#7
voila ce que j'obtient. [ATTACH=CONFIG]560[/ATTACH]
j'ai essayé le paramètrage par ETS dans tout les sens.... Ceci avec l'adresse 4/3/1 avec tout ses participants à read.
je ne sais pas à quoi correspond l'adresse en 18/0/7 et 18/0/9 adresse physique en 15.15.255
Répondre
#8
Bonsoir,

en soi, c'est une bonne chose de remettre tout d'aplomb en interrogeant le bus.
Cela dit, pour les équipements "virtuels" (qui ne sont la que pour la visu et mis à jour avec des automates), ce n'est pas évident.
Il faut tout revoir, relancer les automates à la connexion également en espérant qu'ils soient lancés après la mise à jour des valeurs des équipements sur lesquels ils se basent.
A terme, ça ne serait peut-être pas idiot de faciliter/différentier la gestion de ces équipements.

Julien a écrit :Bonjour,

Suite à la mise à jour, nous avons fait certaines modifications dans notre gestion des états.
Précédemment lors d'un redémarrage d'un serveur nous conservions les anciennes valeurs (qui pouvaient être fausse).
Maintenant nous effaçons tous les états. Au démarrage par contre nous faisons une lecture de toutes les adresses KNX. Je vous recommande de vérifier votre projet KNX si les adresses de lecture ont bien le flag "read". Car une fois actionné, le module doit renvoyer son état et Lifedomus le prend donc en compte.
Vous pouvez aussi vérifier dans le CS si l'actualisation des propriétés est bien "A la connexion".

Pour ce qui est du portail, porte de garage et alarme, je vous conseillerais de regarder du côté du journal d’événements pour comprendre quand Lifedomus aurais agit sur vos équipements.

Julien
Répondre
#9
Bonjour,

@jlr : ce sont des copies lorsque vous agissez sur l'équipement : écriture sur 4/3/0 et réponse sur 4/3/1.
Mais au démarrage du connecteur (Allez dans la partie connecteurs éteignez le connecteur puis allumez le avec la pop-up d'ouverte), vous devriez avoir comme sur mon écran Lecture sur 4/3/1 et réponse de 4/3/1.

@laurent : ce cas a été pensé, nous ne resetons pas les feedback qui sont lié a une adresse de groupe en actualisation Ecriture et qui est aussi en écriture d'un équipement.

Julien
Répondre
#10
C'est de pire en pire.... j'ai eu contact avec la maintenance... on a bouger le projet ETS dans tout les sens et sans sauvegarde...
merci de me joindre pour prendre la main et me dire ce qui ne va pas....
Actuellement, on a l'impression que le version ancienne qui était totalement stable par en guenilles...
plus de trace sur le debugging, alors que çà marche dans la maison....
Répondre


Sujets apparemment similaires...
Sujet Auteur Réponses Affichages Dernier message
  Votre avis ? Pas de réponses suite formulaire options tri35 3 1,313 12-04-2019, 08:58 AM
Dernier message: yann29
  Infos suite box HS david39 24 7,591 12-03-2019, 09:43 AM
Dernier message: 123pc
  Mise à jour "hardware" de la box grichka 13 6,144 03-04-2019, 06:09 PM
Dernier message: AucuneID
  lifedomus vision plus accessible apres mise a jour Totof 1 1,825 12-08-2018, 02:19 PM
Dernier message: Totof
  Demande d'aide Variable Jour/Niut Alexandru 32 17,694 10-02-2018, 06:15 PM
Dernier message: splog
  Problème de certificat suite à mise à jour V2.0.142 bizniouf 1 2,276 11-12-2017, 01:38 PM
Dernier message: jojo
  Demande d'aide Pb suite à MAJ Serveur LD laurent 5 3,337 06-11-2017, 11:50 AM
Dernier message: laurent
  Box HS suite à coupure de courant fbucher 3 2,528 11-27-2016, 05:16 PM
Dernier message: AucuneID
  Problème de mise à jour de LD Jlr 1 1,538 11-14-2016, 08:45 PM
Dernier message: Jlr
  Plus d'accès depuis Smartphone Android te mise à jour LD impossible Ives 5 3,794 04-17-2016, 05:49 PM
Dernier message: Stef86



Utilisateur(s) parcourant ce sujet : 1 visiteur(s)