Demande d'aide Équipement générique ASCII
#1
Bonjour à tous,
Certains ont peut être lu mon message au sujet des Intesisbox sur un autre sujet du forum. J’ai pu avancer sur le « problème », c’est pourquoi je crée un nouveau fil. 

J’ai un Intesisbox pour lequel j’ai créé un équipement universel et j’ai créé une à une les commandes en ASCII. Cela fonctionne correctement, l’envoi des commandes se fait. Cependant, en envoyant des commandes ASCII, il n’est pas offert la possibilité d’utiliser du JS après l’execution de la commande. Pas de problème, je passe par une configuration de la commande en JS via la variable « command ». J’arrive à reproduire l’équivalent des commandes ASCII avec réponse de la part de l’Intesisbox, que je vois dans le Listener. 
J’essaye donc de récupérer la trame avec la variable « trame », tenté différentes façons mais le résultat  est toujours le même. La variable « trame » ressort vide. Je ne sais donc pas si la commande s’est bien exécuté sans aller dans le Listener. 
 
Je peux supposer deux choses : 
1 - Il y a un bug ou une mauvaise configuration de ma part quelque part, mais je pense avoir fait le tour et tout le semble bon
2 - L’Intesisbox répond trop « lentement » ou le retour de trame se passe après avoir terminé l’execution du JS, ce qui explique le retour vide dans ces deux possibilités 

Je ne sais pas si je suis clair, j’espère que oui et du coup je vous demande à l’aide svp. Si quelqu’un a besoin d’explications complétantes pour m’aider, n’hesitez pas. Je vous en remercie d’avance.
Répondre


Sujets apparemment similaires...
Sujet Auteur Réponses Affichages Dernier message
  Equipement Pompe Ives 1 2,184 08-29-2017, 10:34 AM
Dernier message: Pengouin
  Equipement universel Commande : ASCII/JS grichka 6 4,329 05-07-2017, 10:01 AM
Dernier message: Hsd



Utilisateur(s) parcourant ce sujet : 1 visiteur(s)